Which versions of Visual Studio can be used to build applications using Spinnaker, FlyCapture or Ladybug SDKs?

Last Revision Date: 4/4/2016

The following article provides customers with a list of Visual Studio Integrated Development Environments to build applications using the latest versions of the Spinnaker SDK, FlyCapture SDK or Ladybug SDK. See the downloads page for the latest versions.

Operating System Support

This table shows what versions of the Microsoft Visual Studio IDE can be used in a particular OS to build applications using the Spinnaker SDK, FlyCapture SDK or Ladybug SDK.

S = Spinnaker SDK; FC = FlyCapture SDK; LD = Ladybug SDK

   WinXP 32/64-bit  Win7 32/64-bit  Win8.1 32/64-bit  Win10 32/64-bit

Visual Studio 2005 SP1
Note: Except for Win XP 32-bit,
tests used SP1 Vista Update

FC, LD FC, LD FC, LD FC, LD
Visual Studio 2008 FC, LD FC, LD FC, LD FC, LD
Visual Studio 2010 S, FC, LD S, FC, LD S, FC, LD S, FC, LD
Visual Studio 2012 FC FC FC FC
Visual Studio 2013 S S, FC S, FC S, FC
Visual Studio 2015 S S, FC S, FC FC

Note 1: Executables built with Visual Studio 2008 or newer cannot be run on systems without a compatible Visual Studio Redistributable Package. See "Distributing FlyCapture Applications" for information on which versions to download, and for links.

Related Articles